Email Delivery Issues With Microsoft's Free Email Services

Incident Report for Nubinity Network Status

Resolved

This incident has been resolved.
Posted Aug 10, 2025 - 13:08 CDT

Update

We are still in communication with our vendor and waiting on updates on the situation.
Posted Aug 02, 2025 - 12:33 CDT

Update

We are still waiting on a response from our vendor. We will post another update once we hear back.
Posted Jul 30, 2025 - 20:59 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 30, 2025 - 00:23 CDT

Identified

We have identified an issue where emails are not being delivered to customers who are using Microsoft's free email services. We are working with our vendor to get this resolved. We apologize the inconvenience
Posted Jul 30, 2025 - 00:23 CDT
This incident affected: Veilock VPN Services (Service Provisioning - Non Bypass, Service Provisioning - Censorship Bypass).